This document supports the version of each product listed and supports all subsequent versions until the document is replaced by a new edition. To check for more recent editions of this document, see http://www.vmware.com/support/pubs.
You can find the most up-to-date technical documentation on the VMware Web site at:
http://www.vmware.com/support/
The VMware Web site also provides the latest product updates.
If you have comments about this documentation, submit your feedback to:
docfeedback@vmware.com
Getting Started with Capacity Planner

*Getting Started with Capacity Planner* introduces VMware® Capacity Planner and provides initial steps to evaluate business needs and perform an assessment.

**Intended Audience**

This information is intended for technical VMware personnel, such as consultants, the Professional Services Organization, Training, Technical Support, and VMware partners who are responsible for installing and using Capacity Planner in assessment engagements.

**VMware Capacity Planner Documentation**

The complete documentation set for VMware Capacity Planner consists of the following documents.

- *Getting Started with Capacity Planner 3.0*. Introduces you to Capacity Planner and provides some initial steps to get you started.
- *Capacity Planner 3.0 Installation Guide*. Explains preinstallation preparation and planning, installation requirements, installing, initial setup and configuration, and uninstalling.
- *Capacity Planner 3.0 Troubleshooting Guide*. Describes common issues that might occur, such as problems with connectivity, discovery, or data collection, and tips for fixing the problem.
- Capacity Planner online help. Conceptual and procedural information to help you complete a task.
Capacity Planner Overview

Capacity Planner is an IT capacity planning tool for the datacenter and desktop that provides integrated analysis, planning, and decision support functionality to assess an infrastructure.

Using Capacity Planner, you can assess your datacenter and desktop capacity planning needs, consider implementing virtualization, and run consolidation assessments. These assessments help to virtualize and consolidate data center infrastructure, redeploy strategic IT assets, and optimize workload capacity.

With Capacity Planner, you can perform an assessment using Capacity Planner 2.8 and Capacity Planner 3.0 concurrently. With the previous versions of Capacity Planner, you could only view assessment data for that version.

Capacity planning includes the following tasks.
- Balancing workloads on existing computers
- Consolidating work so that fewer computers are needed to perform tasks
- Identifying outdated computers for retirement
- Planning for the purchase of new and more efficient hardware
- Introducing virtual machines to assume some of the work

This chapter includes the following topics:
- “Capacity Planner Component Overview,” on page 7
- “System Requirements,” on page 10
- “Assessment Workflow,” on page 14
- “Data Manager Tasks,” on page 16
- “Dashboard Tasks,” on page 18

Capacity Planner Component Overview

The full Capacity Planner architecture includes the Collector, the Data Analyzer, the Data Manager, and the Information Warehouse.

Data flows between the Capacity Planner Dashboard, Data Manager, Data Analyzer, and Information Warehouse. The Data Manager communicates with the customer's network, as well as the Collector. The Collector runs as a Windows service and performs in the background. Data that the Collector discovers and gathers is stored in a local database. The data goes from the local database back to the Data Manager to be uploaded to the Information Warehouse.

Typically on an hourly basis, data is uploaded from the local Collector database to the Capacity Planner Dashboard.
Data Manager

The Data Manager is the user interface for the Data Collector and is installed with the Collector. The Data Manager provides an organized view of the collected information and is the administrative control for the Collector.

The Data Manager configures the Collector components to perform the following functions.

- Set up and maintain job schedules.
- Set user ID and password combinations for access to target systems.
- Manually run jobs.
- View job progress, especially collection progress.
- Monitor messages that the Collector issues.

The Data Manager also performs the following functions.

- Manages the process by which collected data is sent to the Information Warehouse.
- Provides detailed and summary views and reports on all discovered objects, collected inventory information, and monitored performance data.
- Allows you to start and stop the Collector.

The Collector inventories the existing computers in an IT environment, including the type of computer, operating system, applications or services running on the computer, and so on. The Collector gathers hundreds of performance statistics from each system, such as CPU busy time, CPU idle time, and memory use.
Dashboard

The Dashboard is a Web-based application that you use to interact with the discovered inventory and performance data collected from the customer site during the assessment.

You can view the status of ongoing assessments in the Projects and Companies tabs of the Dashboard Home page. With Capacity Planner 3.0, you can also download Data Manager and manage users from the Dashboard. The Dashboard resides on a secure central host site along with the Data Analyzer and Information Warehouse.

Multiple Version Support

Capacity Planner provides an infrastructure at the company and project level that users can use to retain their data and assessment results from Capacity Planner 2.8.

The Dashboard concurrently supports Capacity Planner 2.8 and Capacity Planner 3.0, while maintaining the same Collector. The added support accelerates the delivery of new features and updates to the Dashboard every two to four months. Users can update their companies, projects, users, and templates without losing data and without interruptions to data collection when they apply new features.

**IMPORTANT** After you migrate companies and projects to Capacity Planner 3.0, you cannot revert back to the previous version.

After you upgrade to Capacity Planner 3.0, you can access the data collected in the previous and current version. The Dashboard displays the companies and projects of Capacity Planner 3.0 and Capacity Planner 2.8.

In Capacity Planner 3.0, when you create a company, project, template, or user, you are prompted to select the version. You can create and use a company, project, template, or user for Capacity Planner 3.0 and Capacity Planner 2.8. In Capacity Planner 2.8, you can create only a company, project, template, or user for that version.

Migrate to Capacity Planner 3.0

You can migrate to Capacity Planner 3.0 and concurrently access companies, projects, users, and templates in Capacity Planner 2.8.

**Prerequisites**

Capacity Planner 2.8 partner company administrator can perform the migration process to Capacity Planner 3.0.

**Procedure**

1. Log in to the Capacity Planner 2.8 Dashboard as a partner company administrator.
2. Click the Companies tab and select a company.
3. Select Administration > Companies.
4. Select the company to upgrade and click the **Upgrade** button.
5. When prompted to upgrade, select appropriately.
   - Select **Yes** to upgrade all of the users within the company.
   - Select **No** to upgrade the administrators in the company.

Capacity Planner 2.8 companies and projects appear under the respective Capacity Planner 3.0 Dashboard tabs.
Upgrade Users from Capacity Planner 2.8

You can upgrade users to Capacity Planner 3.0 while maintaining the same version of the Collector. Capacity Planner 2.8 users have to request the company administrator for an upgrade.

Prerequisites

- Capacity Planner 3.0 administrators have the permission to upgrade users.
- Verify that the associated company is available in Capacity Planner 3.0.
- Capacity Planner 2.8 users must have Access control through group association and roles on Capacity Planner 3.0 companies and projects. For more information on Access control for user groups, see Capacity Planner Online Help.

Procedure

1. Log in to the Capacity Planner 3.0 Dashboard.
2. Click the Companies tab and select a company.
3. Select Administration > Users.
4. Select the users to upgrade and click the Upgrade button.

Capacity Planner 2.8 users can access the Capacity Planner 3.0 companies and projects from the Capacity Planner 2.8 Dashboard tabs.

Information Warehouse

The Information Warehouse is the repository for data that the Collector gathered from all deployed Collectors.

The Capacity Planner Information Warehouse contains a growing set of industry reference data that you can use for comparative analysis and benchmarking. You can use this information to guide validated server consolidation and capacity optimization decisions for the enterprise.

The stored metrics that serve as industry benchmarks are used by the Data Analyzer to perform data analysis. Information in the Warehouse is anonymous. None of the information used in the research features can be traced back to a specific customer, which is how Capacity Planner ensures data privacy. Data collected from one organization cannot be viewed by another organization.

Data Analyzer

The Data Analyzer is the Capacity Planner component that performs the evaluation required for capacity planning, such as comparing results collected for an organization to industry benchmarks and identifying trends.

After analysis, the analyzed data moves to a secure database called the Information Warehouse.

System Requirements

Host and target systems must meet certain requirements to run Capacity Planner.

Capacity Planner Host System Requirements

The host system can be a physical desktop, server, or virtual machine and must meet certain system requirements.

Table 1-1 describes the requirements for a Capacity Planner host system.
Table 1-1. Host System Requirements

<table>
<thead>
<tr>
<th>Category</th>
<th>Requirement</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operating system</td>
<td>Windows 2000 (Server or Professional) SP3, Windows XP Pro, Windows Server 2003, Windows Vista, Windows 7, or Windows Server 2008</td>
<td>The English language version is required. If the Collector is installed on Windows XP SP2, the Windows firewall must be turned off. If the Collector is installed on Windows Server 2003, and collecting from Windows 2000 target systems, use the Windows 2003 R2 SP2 only.</td>
</tr>
<tr>
<td>WMI or remote registry</td>
<td>WMI (Windows Management Instrumentation) or remote registry must be installed</td>
<td></td>
</tr>
<tr>
<td>CPU</td>
<td>Minimum 1.5GHz CPU</td>
<td>Runs on 32-bit and 64-bit, hosts in 32-bit mode</td>
</tr>
<tr>
<td>Memory</td>
<td>Minimum 1GB RAM</td>
<td></td>
</tr>
<tr>
<td>Local Disk</td>
<td>2GB free disk space</td>
<td></td>
</tr>
<tr>
<td>Network Connectivity</td>
<td>Connection to the Internet</td>
<td>Enables connection to the Capacity Planner Dashboard</td>
</tr>
<tr>
<td>Network Bandwidth</td>
<td>20,000 bytes per second during data collection</td>
<td></td>
</tr>
<tr>
<td>Browser</td>
<td>Microsoft Internet Explorer 5.5 or higher</td>
<td></td>
</tr>
<tr>
<td>Virus scanning</td>
<td>Some exceptions might be required for the duration of the assessment</td>
<td></td>
</tr>
</tbody>
</table>

Authentication Requirements

To install and run the Data Manager service, the consultant must have an administrator-level user account for each host. This account must have the privilege of logging on as a service that is configured to start automatically.

Target System Requirements

Target systems for assessment can be physical desktops, servers, or virtual machines.

The target systems for assessment must meet the necessary criteria for data collection. Before collection starts, you must have the answers to the following questions.

Table 1-2. Evaluate your Target System

<table>
<thead>
<tr>
<th>Questions</th>
<th>Answers</th>
</tr>
</thead>
<tbody>
<tr>
<td>What is the number of target systems to be included in the scope of the assessment?</td>
<td></td>
</tr>
<tr>
<td>Does the customer want to identify target systems by using the discovery method or by importing a CSV file?</td>
<td></td>
</tr>
<tr>
<td>How many of the systems are servers?</td>
<td></td>
</tr>
<tr>
<td>How many of the systems are workstations?</td>
<td></td>
</tr>
<tr>
<td>How many of the systems are Windows?</td>
<td></td>
</tr>
<tr>
<td>Of the systems that are Windows, how many are NT systems?</td>
<td>These systems require a different setup to enable data collection.</td>
</tr>
<tr>
<td>How many of the systems are Linux or UNIX?</td>
<td></td>
</tr>
<tr>
<td>How many of the systems are targeted for inventory only?</td>
<td></td>
</tr>
</tbody>
</table>
Table 1-2. Evaluate your Target System (Continued)

<table>
<thead>
<tr>
<th>Questions</th>
<th>Answers</th>
</tr>
</thead>
<tbody>
<tr>
<td>How many systems are targeted for a full analysis, including discovery,</td>
<td></td>
</tr>
<tr>
<td>inventory, and collection of performance metrics?</td>
<td></td>
</tr>
<tr>
<td>Are any of the target systems located behind a firewall in a perimeter</td>
<td></td>
</tr>
<tr>
<td>network (DMZ) and, if so, how many?</td>
<td></td>
</tr>
<tr>
<td>All target domains and systems must be viewable in the network viewing</td>
<td></td>
</tr>
<tr>
<td>area on the host.</td>
<td></td>
</tr>
</tbody>
</table>

Table 1-3. Collection Requirements for Target Systems

<table>
<thead>
<tr>
<th>Microsoft Windows Target Systems</th>
<th>Linux or UNIX Target Systems</th>
<th>All Target Systems</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable Windows Management</td>
<td>Verify that port 22 is open.</td>
<td></td>
</tr>
<tr>
<td>Instrumentation (WMI)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Enable Remote Registry.</td>
<td>Verify that the sshd daemon is running.</td>
<td>Verify network bandwidth availability.</td>
</tr>
<tr>
<td>Enable Performance Monitor</td>
<td></td>
<td>Verify that the Collector can access the target systems with sufficient privileges.</td>
</tr>
<tr>
<td>(Perfmon)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Enable file and print services.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>On Windows NT target systems,</td>
<td></td>
<td></td>
</tr>
<tr>
<td>install and enable WMI and Diskperf service.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Systems Supported for Data Collection

Capacity Planner can collect data from the following target systems.

Table 1-4. Windows and Linux Target Systems

<table>
<thead>
<tr>
<th>Windows Systems</th>
<th>Linux/UNIX systems</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows 2000 Server/Advanced</td>
<td>HP-UX 10.xx (PA-RISC)</td>
</tr>
<tr>
<td>Server/Datacenter</td>
<td></td>
</tr>
<tr>
<td>Windows 2000 Server (64-bit</td>
<td>HP-UX 11 (PA-RISC)</td>
</tr>
<tr>
<td>Itanium)</td>
<td></td>
</tr>
<tr>
<td>Windows 2000 Professional</td>
<td>HP-UX 11.11 (PA-RISC)</td>
</tr>
<tr>
<td>Workstation</td>
<td></td>
</tr>
<tr>
<td>Windows XP Professional</td>
<td>HP-UX 11.22 (PA-RISC)</td>
</tr>
<tr>
<td>(EM64T, AMD 64)</td>
<td></td>
</tr>
<tr>
<td>Windows Server 2003</td>
<td>Sun Solaris 7 (SPARC)</td>
</tr>
<tr>
<td>Windows Server 2003 (64-bit</td>
<td>Sun Solaris 8 (SPARC)</td>
</tr>
<tr>
<td>Itanium)</td>
<td></td>
</tr>
<tr>
<td>Windows Server 2003 (64-bit</td>
<td>Sun Solaris 9 (SPARC)</td>
</tr>
<tr>
<td>x86 / EM64T / AMD64)</td>
<td></td>
</tr>
<tr>
<td>Windows Vista Enterprise</td>
<td>Sun Solaris 9 (x86)</td>
</tr>
<tr>
<td>Windows Vista Business</td>
<td>Sun Solaris 10 (SPARC)</td>
</tr>
<tr>
<td>Windows Vista Ultimate</td>
<td>Sun Solaris 10 (x86)</td>
</tr>
<tr>
<td>Windows 7</td>
<td>SUSE Linux Enterprise 11</td>
</tr>
<tr>
<td>Windows Server 2008</td>
<td>SUSE Linux Enterprise Server 9</td>
</tr>
<tr>
<td>Windows Server 2008 R2</td>
<td>SUSE Linux 10</td>
</tr>
<tr>
<td></td>
<td>SUSE Linux 9</td>
</tr>
<tr>
<td></td>
<td>SUSE Linux 8</td>
</tr>
<tr>
<td></td>
<td>Red Hat Linux 8</td>
</tr>
<tr>
<td></td>
<td>Red Hat Linux 9</td>
</tr>
<tr>
<td></td>
<td>Red Hat Enterprise Linux 6</td>
</tr>
</tbody>
</table>
Table 1-4. Windows and Linux Target Systems (Continued)

<table>
<thead>
<tr>
<th>Windows Systems</th>
<th>Linux/UNIX systems</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Red Hat Enterprise Linux (ES/AS/WS) 5</td>
</tr>
<tr>
<td></td>
<td>Red Hat Enterprise Linux (ES/AS/WS) 4</td>
</tr>
<tr>
<td></td>
<td>Red Hat Enterprise Linux (ES/AS/WS) 3</td>
</tr>
<tr>
<td></td>
<td>AIX 5.1</td>
</tr>
<tr>
<td></td>
<td>AIX 5.2</td>
</tr>
<tr>
<td></td>
<td>AIX 5.3</td>
</tr>
</tbody>
</table>

Target System Port Availability Requirements

The Collector host must be able to connect to all target systems using specific protocols and ports.
All ports use TCP/UDP protocol.

Table 1-5. Port Availability Requirements for Target Systems

<table>
<thead>
<tr>
<th>Port</th>
<th>Service</th>
<th>Description</th>
<th>MS Windows Services Using This Port</th>
</tr>
</thead>
<tbody>
<tr>
<td>22</td>
<td>Secure Shell (SSH)</td>
<td>Used for secure logins, file transfers, and port forwarding</td>
<td></td>
</tr>
<tr>
<td>135</td>
<td>loc-srv/epmap</td>
<td>Microsoft Data Communications Exchange (DCE) Locator, also known as End-point Mapper</td>
<td>DHCP Server, DNS Server, WINS Server</td>
</tr>
<tr>
<td>137</td>
<td>netbios-ns (NetBIOS names service)</td>
<td>Firewall administrators frequently see large numbers of incoming packets to this port because as users behind firewalls browse Windows-based Web sites, those servers frequently respond with NetBIOS look-ups.</td>
<td>DNS Server, WINS Server</td>
</tr>
<tr>
<td>138</td>
<td>netbios-dgm (NetBIOS datagram)</td>
<td>Port 138 is used primarily by the Server Message Block (SMB) browser service that obtains Network Neighborhood information.</td>
<td>DNS Server</td>
</tr>
<tr>
<td>139</td>
<td>netbios-ssn (NetBIOS session)</td>
<td>Windows file and printer sharing</td>
<td></td>
</tr>
<tr>
<td>445</td>
<td>DNS (Domain Name Service (DNS) Direct Hosting port)</td>
<td>In Windows 2000 and XP, redirector and server components support direct hosting for communicating with other computers running Windows 2000 or XP.</td>
<td>Active Directory</td>
</tr>
</tbody>
</table>

Target System Authentication Requirements

Account credentials are required on all target systems that are to be included in the assessment data collection.
The onsite system administrator can provide a global connection account that has local administrator rights on all the target systems that are to be analyzed. If this account cannot be arranged for security reasons, the onsite system administrator can set accounts, or credentials, in the Data Manager. User account information is stored in the local Collector database, not in the Information Warehouse.
Assessment Workflow

The assessment timeline includes managing tasks from the Data Manager, Collector, and Dashboard.

**Figure 1-2. Engagement Timeline and Workflow**

<table>
<thead>
<tr>
<th>Timeline</th>
<th>Workflow</th>
<th>Customer Site</th>
<th>Dashboard</th>
</tr>
</thead>
<tbody>
<tr>
<td>before project starts</td>
<td>pre-assessment consultation</td>
<td></td>
<td></td>
</tr>
<tr>
<td>week 1</td>
<td>assessment begins</td>
<td></td>
<td>Start Server or Desktop Project for New Customer Company from Home Page</td>
</tr>
<tr>
<td>week 2</td>
<td>monitoring and data inspection</td>
<td></td>
<td>Monitoring</td>
</tr>
<tr>
<td>Consolidation Estimate (CE) Projects ends</td>
<td></td>
<td>Analysis and Findings</td>
<td></td>
</tr>
<tr>
<td>week 3</td>
<td>continue gathering data for improved results</td>
<td></td>
<td>Final Analysis</td>
</tr>
<tr>
<td>week 4</td>
<td>Server and Desktop Projects ends</td>
<td></td>
<td>Prepare Reports</td>
</tr>
<tr>
<td>after project ends</td>
<td>post-assessment consultation</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Types of Projects

Each type of assessment has a different goal.

Table 1-6. Assessment Types and Results

<table>
<thead>
<tr>
<th>Assessment Type</th>
<th>Description</th>
<th>Assessment Performed By</th>
<th>Results</th>
</tr>
</thead>
<tbody>
<tr>
<td>Consolidation Estimate (CE)</td>
<td>Estimate of the potential savings from implementing an assessment. Only key inventory and performance metrics are collected over a period of several days.</td>
<td>Sales engineers, partners or consultants who have not attended Capacity Planner training as well as trained partners and consultants.</td>
<td>Two consolidation and virtualization scenarios, one aggressive and one conservative. Standard interim and final reports.</td>
</tr>
<tr>
<td>Consolidation Analysis (CA)</td>
<td>A thorough study that collects inventory and performance metrics over a month or longer, taking into account monthly fluctuations. Provides a detailed analysis of potential savings available through consolidation and virtualization.</td>
<td>Only trained partners and consultants.</td>
<td>Unlimited consolidation and virtualization scenarios. Standard interim and final reports as well as detailed analytical reports, such as forecasting, alerts, and anomaly detection.</td>
</tr>
<tr>
<td>Virtual Desktop Infrastructure (Desktop)</td>
<td>A thorough study that collects inventory and performance metrics for networks, subnets, locations, users, and logins taking into account monthly fluctuations to help users analyze Virtual Desktop Infrastructure (Desktop) environment readiness for virtualization.</td>
<td>Only trained partners and consultants.</td>
<td>Unlimited consolidation and virtualization scenarios. Standard interim and final reports as well as detailed analytical reports, such as forecasting, alerts, and anomaly detection.</td>
</tr>
</tbody>
</table>

Starting an Assessment

You can start a new company to gather and convey information. Instead of creating a separate company for each type of assessment, you can create multiple CA, CE, or Desktop projects within the same company.

Projects use the same data collected within a company for performing different assessments. You can view the status of ongoing assessments on the Projects and Companies tabs of the Dashboard home page.

Gather the following information before an assessment begins, to inform the direction the assessment takes.

- Determine the organization’s goals for performing the assessment and decide what type of assessment would meet those goals.
- Collect information about computers in the organization’s environment, such as number, location, and type. Computers being assessed are referred to as target systems and can be Microsoft Windows, Linux, or UNIX computers (either servers or workstations).
- Scope the assessment to determine whether to evaluate all target systems in the organization or only a subset.
- Understand the organization’s network and security infrastructure. Consultants performing an assessment need access to target systems to collect inventory and performance data.
- Discuss authentication, network connectivity, and security issues that might need to be resolved before data collection.
Exchange contact information, such as telephone and email address, for all members of the assessment team.

Decide on a host system on which to install the software to gather and upload the data.

Post-Assessment Tasks

Post-assessment tasks include presenting final reports and proposals, conducting any follow-up tasks that were previously agreed upon, and uninstalling the Data Manager from the host computer.

After the assessment concludes, you can present the results of the data analysis and a proposal for consolidation and virtualization.

You can uninstall the Data Manager from the host computer or deactivate the database ID. Either action stops data from being collected and uploaded to the Information Warehouse.

Data Manager Tasks

After the Data Manager is installed, you identify systems and collect data.

- Identifying Systems on page 16
  You can identify systems to collect data from either by discovery or by importing a .csv list.
- Data Collection on page 17
  Data collection focuses on inventory and performance information.

Identifying Systems

You can identify systems to collect data from either by discovery or by importing a .csv list.

An organization might want to evaluate all target systems in the organization, or a subset of the systems.

If you have find connectivity problems, you can correct them at this time by using the Test Connection feature in the Data Manager.

Specify a schedule for additional discovery jobs to take place during the assessment to find target systems that were not in service but are restored to service during the assessment period.

The Data Manager includes a navigation pane with a navigation tree that shows which target systems were imported and how the target systems might be grouped by domain, department, physical location, and so on. Review the target systems that appear in the navigation pane to verify that the systems shown match the scope of the assessment agreed upon in the preassessment consultation.

Discovering Systems

You can start the discovery process in the Data Manager.

This method has the advantage of helping organizations find target systems that might be forgotten.

After Capacity Planner is installed and configured, confirm whether the Collector has discovered the target systems that an organization wants to evaluate. The discovery process validates that all target systems are found.

Importing Systems

You can import a list of systems to collect data from.

You can import The target systems from a list in a comma-separated values (CSV) file. If this list is the exclusive source of systems to be assessed, computers in the network that are not on the import list are not evaluated during the assessment. The list is typically agreed upon during the preassessment consultation.
Data Collection

Data collection focuses on inventory and performance information.

Inventory Data Collection

Inventory data collection finds hardware and software information for each target system. Inventory is attempted every day for systems that have not been inventoried. Inventory data includes the following information about a target system.

<table>
<thead>
<tr>
<th>CPU</th>
<th>Memory</th>
</tr>
</thead>
<tbody>
<tr>
<td>Physical disks</td>
<td>Network interface cards (NICs)</td>
</tr>
<tr>
<td>Services or daemons</td>
<td>Applications</td>
</tr>
<tr>
<td>Shares</td>
<td>File systems</td>
</tr>
<tr>
<td>Users</td>
<td>User groups</td>
</tr>
<tr>
<td>Logins</td>
<td>Networks</td>
</tr>
<tr>
<td>Locations</td>
<td>IP subnets</td>
</tr>
</tbody>
</table>

Performance Data Collection

Performance data collection is a sampling of statistical information collected from each target system. The sampling is done using hundreds of performance counters, such as % Idle Time, % Processor Time, network latency, and network session time. The counters provide average, mean, minimum, and maximum performance statistics. Performance collection occurs every hour.

Excluding Information from Collection

You can configure the Collector to exclude categories of information from inventory or counters from performance collection. Excluded information is not evaluated by the Data Analyzer or uploaded to the Information Warehouse.

Typical Assessment

The typical CA, CE, or Desktop assessment lasts four weeks to accommodate monthly fluctuations in activity, such as a month-end billing cycle. The exception is a CE assessment. Because a CE is only an estimate, collection is typically done for just a few days. For more information on types of assessments, see “Types of Projects,” on page 15.

After installation and the discovery phase is complete, the Data Manager is left running on the host at the customer site and continues to collect inventory and performance data. You can monitor the activity remotely from the Capacity Planner Dashboard and make corrections as needed.

Capacity Planner collects data by using the following utilities that are provided with the target system’s own operating system.

- Windows Management Instrumentation (WMI)
- Remote Registry
- Remote Procedure Call (RPC)
- Perfmon
- Secure Shell (SSH)
**Dashboard Tasks**

After setup is complete and data collection progresses, you can review the results, create consolidation scenarios to model potential changes, and create reports from the Dashboard.

You can perform tasks in the Dashboard after the first week of data collection.

**Monitoring**

You can check the progress of your assessment in the Projects and Companies tabs of the Dashboard.

The inventory and performance success rate is summarized week by week for the data collected in the past 12 weeks. If problems occur, such as the Collector being stopped, a notification is sent to you.

**Analysis**

After a week of collection, you can view the results of the data collection in the Dashboard.

Several data views in the Dashboard provide this information.

<table>
<thead>
<tr>
<th>Data View</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Forecast Critical</td>
<td>A list of target systems and the number of weeks until each target system reaches a critical usage point (greater than 50% of capacity).</td>
</tr>
<tr>
<td>Processors</td>
<td></td>
</tr>
<tr>
<td>System Processor Load</td>
<td>A summary of how each server or workstation is used during standard business hours compared to use during the peak hour (the highest use in a 24-hour period).</td>
</tr>
<tr>
<td>View</td>
<td></td>
</tr>
<tr>
<td>Anomalies Summary</td>
<td>A summary of target systems with performance data that deviates from industry average values.</td>
</tr>
<tr>
<td>Vintage Systems</td>
<td>A view of target systems operating below a minimum performance threshold.</td>
</tr>
<tr>
<td>Base Image Manager</td>
<td>You can work with templates based on software profiles with an approved operating system that are used to create a consolidation profile that uses new virtual machines.</td>
</tr>
</tbody>
</table>

**Modeling**

As the assessment enters the third or fourth week of data collection, you can prepare preliminary consolidation and virtualization models called scenarios.

By trying various scenarios, you can determine more efficient and cost-effective ways to structure the IT setup.

When you prepare scenarios, consider several approaches. One scenario might suggest more aggressive recommendations and another a more moderate approach. A scenario might include recommendations to purchase new hardware to increase efficiency or to introduce virtualization technology on existing target systems to balance the workload.

**Reporting**

Preparing reports is a final step in a capacity planning engagement.

As the assessment period ends, you can run final scenarios and prepare reports for presentation of the assessment findings.
With application analysis, you can analyze applications and select applications for software profile management and base image management.

The application analysis workflow has several stages. Desktop applications are analyzed to determine what common applications are used by different users. From this analysis, software profiles are created. The software profiles are used to create base images. The steps in this process are collecting, filtering, sorting information into base images, sizing the virtual machines, and placing them in a database.

**Figure 2-1. Application Analysis Process**

This chapter includes the following topics:

- “Software Profiles,” on page 20
- “Base Images,” on page 20
- “Sizing Virtual Machine Templates,” on page 20
- “Performing Basic Tasks Using Capacity Planner,” on page 21
Software Profiles

Software profiles are used to analyze application use. The analysis is used to create base images that reflect user patterns.

Capacity Planner uses software profiling to standardize the use of applications and operating systems. Profiles can be linked to indicate that standardization should be done if an application appears. You can determine what applications or operating systems to use to create profiles.

Base Images

Application inventory analysis creates base images and ThinApp images.

ThinApp images contain applications that are approved virtualization candidates. ThinApp images are used to virtualize applications without virtualizing entire systems.

Base images contain software profiles, ThinApp applications, and an operating system.

Figure 2-2. Application Analysis Assists Base Image Creation

Sizing Virtual Machine Templates

Base images are used to create virtual machine templates, which can be sized or configured to estimate hardware and software requirements.

A virtual machine template contains an operating system, software, and virtual machine sizing parameters. Each virtual machine is sized, based on usage and configuration, into three categories: low, medium, or high. You can evaluate the CPU, memory, or disk usage and categorise the virtual machine template into low, medium, or high.
Performing Basic Tasks Using Capacity Planner

After you become familiar with the Capacity Planner components, you can perform basic tasks such as starting a new project or company.

Table 2-1. Basic Capacity Planner Tasks

<table>
<thead>
<tr>
<th>Task</th>
<th>Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create your account in the Dashboard.</td>
<td><a href="http://optimize.vmware.com">http://optimize.vmware.com</a></td>
</tr>
<tr>
<td>Start a new company.</td>
<td>Select Dashboard &gt; Home &gt; Start new Company and select the Capacity Planner version to use.</td>
</tr>
<tr>
<td>Start a new project.</td>
<td>Select Dashboard &gt; Home &gt; Start new Project and select the Capacity Planner version to use.</td>
</tr>
<tr>
<td>Set up the company to be assessed.</td>
<td>Select Dashboard &gt; Administration &gt; Company Setup.</td>
</tr>
<tr>
<td>Download and install the Data Manager.</td>
<td><a href="https://www.vmware.com">Capacity Planner 3.0 Installation Guide</a></td>
</tr>
<tr>
<td>Add accounts for target systems.</td>
<td>Select Data Manager &gt; Objects &gt; &lt;system&gt;.</td>
</tr>
<tr>
<td>Connect to the target systems and test the data collection.</td>
<td>Select Data Manager &gt; Home &gt; Test Collection.</td>
</tr>
<tr>
<td>Register the Collector.</td>
<td>Select Data Manager &gt; Home &gt; Register Collector.</td>
</tr>
<tr>
<td>Register a database ID.</td>
<td>Select Dashboard &gt; Company &gt; Register Database IDs or Dashboard &gt; Project &gt; Register Database IDs.</td>
</tr>
<tr>
<td>Synchronize the data upload from the Collector to the Dashboard and test the synchronization.</td>
<td>Select Data Manager &gt; Home &gt; Synchronize Data.</td>
</tr>
<tr>
<td>Create systems templates.</td>
<td>Select Dashboard &gt; Company &gt; Project Tools &gt; System Templates.</td>
</tr>
<tr>
<td>Create software profile templates.</td>
<td>Select Dashboard &gt; Company &gt; Project Tools &gt; Software Profile Templates.</td>
</tr>
<tr>
<td>Create a new user.</td>
<td>Select Dashboard &gt; Administration &gt; Users.</td>
</tr>
<tr>
<td>Task</td>
<td>Location</td>
</tr>
<tr>
<td>---------------------</td>
<td>-----------------------------------------------</td>
</tr>
<tr>
<td>Set up notifications.</td>
<td>Select Dashboard &gt; Administration &gt; Notifications.</td>
</tr>
<tr>
<td>Run reports.</td>
<td>Select Dashboard &gt; Reports.</td>
</tr>
</tbody>
</table>
# Index

**A**
- analysis 18  
- anomalies 18  
- application analysis 19  
- applications 20  
- assessment 15, 18  
- assessment workflow 14  
- authentication 13  

**B**
- base image manager 18  
- base images 19, 20  
- basic tasks 21  
- benchmarks 10  

**C**
- capacity planning 7  
- collection dashboard 18  
- Collector 7, 8, 10  
- configure tasks 8  
- connectivity 16  
- consolidation 18  
- consolidation analysis 15  
- consolidation estimate 15  
- consolidation scenarios 18  
- CPU 10  
- critical processors 18  
- CSV 11, 16  

**D**
- Dashboard 7, 9, 18  
- Data Analyzer 7, 9, 10  
- Data Manager 7, 8, 16  
- Data Manager tasks 16  
- desktop 15  
- discovery 16  
- DNS 13  

**F**
- forecast critical processors 18  

**G**
- global connection account 13  

**I**
- images 20  
- importing systems 16  
- Information Warehouse 7, 9, 10  
- information, exclude 17  
- intended audience 5  
- inventory data 17  
- IT environment 8  

**L**
- Linux 16  

**M**
- MDAC 10  
- memory 10  
- metrics, stored 10  
- migrate 9  
- modeling 18  
- monitoring 18  
- multiple version support 9, 10  
- My Assessments table 18  

**N**
- navigation pane 16  
- navigation tree 16  
- NetBIOS 13  
- network connectivity 10  

**O**
- operating system 10  

**P**
- Perfmon 11, 17  
- performance data 17  
- ports 13  
- post-assessment 16  
- pre-assessment consultation 16  
- printer sharing 13  
- processor load 18  
- project 15  

**R**
- remote registry 10, 17  
- reports 18  
- repository 10
RPC 17

S
scenarios 18
secure shell session 16
sizing 20
software profiles 20
SSH 13, 16, 17
standardization 20
system requirements 10

T
TCP/UDP protocol 13
template, virtual machine 20
ThinApp images 20
trends 10
typical assessment 17

U
UNIX 16
upgrade 9, 10

V
vintage systems 18
virtual desktop infrastructure 15
virtual machine 20
virtual machine template 20
virtualization models 18

W
WMI 10, 11, 17