Troubleshooting Guide

Capacity Planner 3.0

This document supports the version of each product listed and supports all subsequent versions until the document is replaced by a new edition. To check for more recent editions of this document, see http://www.vmware.com/support/pubs.

EN-000691-00
You can find the most up-to-date technical documentation on the VMware Web site at:
http://www.vmware.com/support/
The VMware Web site also provides the latest product updates.
If you have comments about this documentation, submit your feedback to:
docfeedback@vmware.com
Contents

Capacity Planner Troubleshooting Guide  5

1 Troubleshooting Overview  7
   Track the Current Status and Activity  7
   Use Capacity Planner Log Files  8
   General Connectivity Issues  8
   Discovery Troubleshooting  9
   Windows Troubleshooting Tools  13
   Problems with Dashboard Access to the Data  15
   General Collector and Data Manager Issues  18
   Problem with Performance Access Rights  21

2 Error Codes  25
   Data Collection Errors  25
   Data Synchronization Errors  31
   Miscellaneous Errors  32

Index  33
Capacity Planner Troubleshooting Guide

The Capacity Planner Troubleshooting Guide provides information about troubleshooting, security, and using Linux and UNIX scripts.

Intended Audience

This information is intended for technical VMware personnel, such as consultants, the Professional Services Organization, Training, Technical Support, and VMware partners who are responsible for installing and using Capacity Planner in assessment engagements.

VMware Capacity Planner Documentation

The complete documentation set for VMware Capacity Planner consists of the following documents.

- **Getting Started with Capacity Planner 3.0.** Introduces you to Capacity Planner and provides some initial steps to get you started.
- **Capacity Planner 3.0 Installation Guide.** Explains preinstallation preparation and planning, installation requirements, installing, initial setup and configuration, and uninstalling.
- **Capacity Planner 3.0 Troubleshooting Guide.** Describes common issues that might occur, such as problems with connectivity, discovery, or data collection, and tips for fixing the problem.
- **Capacity Planner 3.0 Reference Guide.** Provides detailed information about inventory objects, performance counters, Linux and UNIX utilities, and Linux and UNIX data collection scripts.
- **Capacity Planner 3.0 Release Notes.** Contains descriptions of known issues and workarounds.
- Capacity Planner online help. Conceptual and procedural information to help you complete a task.
Troubleshooting Overview

Known troubleshooting information can assist you in solving common issues.

If you have a problem that is not mentioned in this information or in the Release Notes, check the VMware Knowledge Base. If none of these resources address your problem, report the problem to Capacity Planner Technical Support.

This chapter includes the following topics:

- “Track the Current Status and Activity,” on page 7
- “Use Capacity Planner Log Files,” on page 8
- “General Connectivity Issues,” on page 8
- “Discovery Troubleshooting,” on page 9
- “Windows Troubleshooting Tools,” on page 13
- “Problems with Dashboard Access to the Data,” on page 15
- “General Collector and Data Manager Issues,” on page 18
- “Problem with Performance Access Rights,” on page 21

Track the Current Status and Activity

You can view the current status and most recent activity in the Data Manager.

Procedure

◆ Select View > Message Box.

The level of detail in the messages is determined by the logging level.

The status bar at the bottom of the window shows which job is currently running.
Use Capacity Planner Log Files

The log files are standard text files. When problems occur, examine the log files to determine whether an error message was reported or other information was recorded. If you cannot find enough information in the log file to help explain the problem, raise the logging level and repeat the sequence of events that triggered the problem.

When the Collector is installed and run on its host system, a log file is created in the installation directory. The Collector records the activities that occur during processing in the log file. When the log file fills up, it is archived, and a new log file is created. The number and size of the log files is set in the Options dialog box.

CAUTION  Prolonged logging at a high level can quickly fill your log file, consume available disk space, and possibly affect performance of the Collector. Limit use of detailed logging to troubleshooting a possible problem with the Collector.

Procedure

1. Start the Capacity Planner and select Admin > Options.
2. Move the log level slider to the setting you want and click OK.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Off - Errors Only</td>
</tr>
<tr>
<td>1</td>
<td>Follow Progress</td>
</tr>
<tr>
<td>2</td>
<td>Detail Progress (the default)</td>
</tr>
<tr>
<td>3</td>
<td>Light Debugging</td>
</tr>
<tr>
<td>4</td>
<td>Detail Debugging</td>
</tr>
<tr>
<td>5</td>
<td>Trace Mode</td>
</tr>
</tbody>
</table>

As the logging level increases, so does the amount of detailed information that is recorded in the log file (and also displayed in the Message pane of the Data Manager window).

General Connectivity Issues

Firewalls or unmanaged systems in the collection environment can cause connectivity issues.

Firewalls

Firewalls provide security for systems from intruders. Firewalls can also prevent access for legitimate administrative users. If several systems are in a location behind a firewall, you might need to install the Collector and Capacity Planner on a host system within the firewall.

Unmanaged Systems

The network environment for a company might include some unmanaged systems that are connected to the network, but not joined into any domain. To connect to an unmanaged system, the Collector must use a local administrative account for that system.

This situation can happen after a company merger or an acquisition. A transition plan might exist for defining the management of these new systems, but until the plan takes effect, many of these systems are connected to the network, but not joined to any domain.
Discovery Troubleshooting

The majority of discovery problems occur when the Collector cannot reach the name service from its physical location or through established network rules. These rules include firewalls, subnet masks, authentication, and network card configuration settings.

The discovery process relies on the network configuration at the target site. If there are problems with the discovery of a particular target system or group of systems, the first step is to identify what is missing and investigate the network configuration.

The Collector uses the same APIs to populate the network neighborhood. If certain target domains or systems are expected to be discovered, but are not found during the discovery process, go into the All Objects branch in the Navigation pane of the Collector host and verify that the expected domains and systems can be seen.

When target domains or systems are not discovered, consider these possible workarounds:

- If specific domains are missing, manually add the missing domains with the Capacity Planner. This approach often results in discovery of systems in the added domains. If a file of missing domains and systems is available, the Capacity Planner can import those domains and systems from the file.
- For domains that are not providing complete server listings, make sure that the Collector host has WINS servers listed for those domains.
- Create an LMHOSTS file with entries for missing domains and the corresponding primary domain controllers.
- If a list of target systems is available, but the associated domains are unknown and it is too time-consuming to identify the associated domains, you can create a dummy domain and the import the target systems.
- A target system within a Microsoft LAN Manager domain resolves with its short name, and Capacity Planner can collect inventory and performance information without the proper domain name.

Bad Path

A Bad Path error message is displayed when a host name cannot be resolved to an IP address or the IP address cannot be reached.

Problem

A Bad Path error message appears.

Cause

A bad path error is typically caused by the following problems:

- Name resolution. The host name cannot be resolved to an IP address.

Because these problems can manifest themselves in several ways, numerous possible solutions exist. Name resolution problems are not connectivity problems. Name resolution involves getting the correct physical address for a system. Typically, name resolution problems occur for the following reasons:

- The system no longer exists on the network and has been gone long enough to be removed from Active Directory, WINS, or browser synchronization.
- If system names are imported, either a system name was misspelled or the system name is not resolvable.
- The system was moved to another domain, and because the Collector host uses a fully qualified domain name (FQDN) to contact the system, the name is incorrect.
If a short name is used for the target system path instead of the FQDN, the domain of the Collector host is appended to the end of that short name. If a bad path error is encountered, the Collector host might be in a domain that cannot resolve the remote system.

The best tools to verify the path to a target system are the `ping` and `nbtstat` commands.

- Connection to the IP address. The returned IP address cannot be reached.

**Solution**

- To correct a name resolution problem, edit the local `LMHOST` file.
  - Use the `nslookup` command to verify that the hostname is resolvable.
  - Change the `LMHOST` file but not the `HOST` file because Capacity Planner uses some APIs for LAN Manager protocols.
- Connection to the target system IP address might not be accomplished for the following reasons:
  - The system is temporarily off the network.
  - A system is not connected to the network and was not removed by the name resolution service. This occurrence is common for Active Directory, which does not remove systems from the database when they go offline.
  - The system is in a location that prevents connection either by router configuration or a firewall.
  - This problem can be difficult to diagnose. In many cases, one protocol or port is allowed, but another is not. For example, you might be able to ping a target system by its host name, yet you cannot map a drive on that system.
  - Make sure that the protocols used by Capacity Planner are successful. Use the **Test Connection** menu command in the Capacity Planner.

**Naming Services**

Problems can occur with the WINS or Active Directory Naming Services.

**Problem**

WINS or Active Directory issues occur.

**Cause**

If problems are encountered when trying to access the WINS servers, it is usually because of incorrect network card settings or the presence of firewalls in the network.

If you get an error that indicates a table is missing during discovery, it is most likely that the Active Directory is unreachable or is not allowing your query.

**Solution**

- To resolve WINS issue, check and correct your network card settings or adjust your firewall settings.
- To correct WINS issue, check your Active Directory documentation.

**Unknown User**

The unknown user error occurs when the user account that the Collector is using is not known to a target system.

**Problem**

An Unknown User error message appears.
Cause

If the Collector host is using a local account to connect to a remote system, the account probably does not exist on that system. If the Collector host is using a domain account, the error might occur for the following reasons:

- The target system might belong to a different domain and might not have a trust relationship with the domain the user account belongs to.
- The target system is part of a workgroup instead of a member of a domain.

The unknown user error might also occur for other reasons that might be difficult to determine.

Solution

- You must use the same account credentials to connect to the system through both of the discovered types, LAN Manager and Active Directory, to make sure that the Collector can connect to the system for inventory and performance data collection.

  If a target system is a member of a domain that is discovered by using both LAN Manager and Active Directory APIs, the credentials might conflict or be invalid during certain tasks when the Collector accesses this system.

Access Denied

An Access Denied error message is displayed when an incorrect password is entered.

Problem

The Collector host can be denied access to a remote system if it is trying to connect with an invalid password.

Cause

The remote system might be configured to allow remote access only for specific users accounts or groups or only for specific domains or network paths.

You might receive an access denied message if there is no trust relationship for the domain. An untrusted domain is usually indicated by an unknown user error.

Solution

- If you have a correct password, re-enter it. If not, ask your system administrator for a password.

Administrator Privileges

The account used by the Collector host must be in the Administrators group on the remote system.

Problem

You are able to log on and the connection appears to be successful. However, there are problems with inventory and data collections due to a lack of access privileges.

Cause

Some environments default to a guest account if the provided user name and password are incorrect. This action gives the false impression that the user account or password is correct and connection was successful. This situation can lead to later problems with inventory and data collection, because a guest does not have privileges to access the data on the remote system.

Solution

- If the Collector host is using an account that is not the local administrator account, verify that the account is added to the Administrators group on the remote system.
Testing the Access Paths

Access paths that the collector host uses include Remote Registry access, WMI access, and the performance database.

Problem
Access path error occurs.

Cause
There is an issue within the access paths or the performance database.

Solution
- To find the problem, test the Performance Monitor by starting it and adding some counters for the remote system.
  
  If the test fails, there is a problem with the user account.

Logon Server Not Available

The Logon Server Not Available error message appears when the domain controllers cannot be contacted.

Problem
The Logon Server Not Available error message is displayed.

Cause
The domain controllers for the user’s domain cannot be contacted.

Solution
If the Collector host is using a domain user account, the Logon Server Not Available error can occur if none of the domain controllers for the user’s domain can be contacted. If this problem occurs, try the following actions:

- Check whether the domain name was mistyped. If the domain name is incorrect, the remote system cannot resolve any of the domain controllers for that domain.

- Log in to the remote system with any account and ping one of the domain controllers. This action determines whether or not the network path from the remote system to the domain is accessible.

Test for an RPC Error

A remote procedure call (RPC) error indicates that a connection requested on a specific port was not successful. RPC connection requests occur after name resolutions and IP connections. The most common cause of an RPC error is that the RPC service is shut down.

Procedure
1. Determine whether the host name is resolvable by executing the NBTSTAT command.
   
   NBTSTAT -a hostname

2. If you can resolve the host name, try to connect to the system with the net use command.
   
   net use \hostname $IPC
If you cannot connect, one of the services, Remote Registry, WMI, or Perfmon, is disabled. The `net use` command also confirms that the required ports are available for the Collector to run inventory and performance.

**Some Domains Not Discovered**

You must install the host machine on a server that has access to the Active Directory server.

**Problem**
The Collector cannot discover domains or machines.

**Cause**
If you select a host that is located in a Windows workgroup, the Collector cannot discover domains or machines stored in the Active Directory.

**Solution**
- When selecting the host machine to install the Collector on, select a machine in a domain that has access to the Active Directory server.

**Windows Troubleshooting Tools**

Several Windows commands and utilities are helpful in troubleshooting problems that the Collector encounters during discovery, inventory, and performance collection.

Unless otherwise noted, detailed information about these commands and utilities is provided in the online Help of your Windows system. These commands are described in relation to their use on the Collector host.

**ping Command**

You can use the `ping` command to verify connections to remote computers and confirm that the remote system is online and responding.

Ping can be useful in determining whether your system is online, but a successful ping does not guarantee that collection will be successful. A failed ping can mean that the system or network does not allow Internet Control Message Protocol (ICMP) traffic.

**Example: ping Example**

The following command tests the ability to connect to `abcserver` by sending packets to it and waiting for a response from the remote system. The connection is made by resolving the host name of the remote system.

```
ping abcserver
```

The results from this command indicate the degree of success of the connection attempt and the round-trip time statistics.

**nbtstat Command**

The `nbtstat` command is a diagnostic command that helps determine how a system name or IP address is resolved. Because the command can display current connections that are using NetBIOS over TCP/IP (NBT), it is useful for determining if Windows systems are online from a NETBIOS view.

**Example: nbtstat Example**

The following command lists the name table for `abcserver`, resolving access to that remote system by its host name:
nbtstat -a abcserver

**net view Command**

You can use the `net view` command to display domains or computers or shared resources that can be accessed from the local system.

The `net view` command is one of a collection of network (net) commands.

**Example: net view Example**

The following command determines which shared resources are available at abcserver.

```plaintext
net view \abcserver
```

When used without parameters, `net view` displays a list of computers in the domain of the local system. To display a list of computers in another domain, use a command such as the following example:

```plaintext
net view /domain:abcdomain
```

**net use Command**

The `net use` command is a Windows network command. Typically, you use this command to connect to or disconnect from a remote computer or shared resource. This command can also provide information about existing connections, which makes it a useful tool to verify that the Collector host can connect with this account.

**Example: net use Example**

The following command connects to abcserver with user ID abcuser.

```plaintext
net use \abcserver\ipc$ /USER:abcuser
```

A variation on the preceding command connects to abcserver for the purpose of remote administration and ensures that the abcuser account has administrator privileges on abcserver:

```plaintext
net use \abcserver\admin$ /USER:abcuser
```

**Perfmon Command**

The Perfmon utility can help to verify that a remote system can be monitored. This command can also add performance counters from a remote system.

However, Perfmon only works locally as a troubleshooting tool. Because Remote Registry and File and Print services use the same ports as Perfmon, you can test access to a target system with those tools. Running Perfmon locally on a problem system allows you to verify that the necessary services are running correctly and that the correct counters are installed for Performance data collection.

**tracert Command**

Also called traceroute (or tracepath on some Linux systems), the `tracert` tool allows you to determine the route IP packets use as they navigate an IP network.

The `tracert` tool shows the route taken to reach a particular destination on the network and is useful for troubleshooting the network.
Connect to Remote Systems with the Computer Management Utility

The Computer Management utility is an administrative tool that allows you to manage your local system and remote systems to which you have access. This tool helps you determine whether WMI is working on the remote system.

You can also verify your access rights on a remote system by navigating through the console tree in different areas and looking for Access Denied or Access is Denied errors.

Procedure

2. Right-click the top level of the navigation tree and select the remote system to connect to.

Connect to a System with the Registry Editor

You use the Registry Editor to view and edit the Registry on your local system. You can also use this tool to test Windows Registry connectivity to a remote system.

Windows provides two forms of the Registry Editor: regedit.exe and regedt32.exe. Microsoft recommends using regedit as the preferred utility for general browsing and searching of the Registry.

**CAUTION** Be careful when you access a Windows Registry. If any key in the Registry is inadvertently and incorrectly modified, operation of that Windows system can be severely affected.

Procedure

1. Select Start > Run and specify the utility name.
2. To connect to the Registry of a remote computer, select Connect Network Registry from the File menu.

PuTTY

PuTTY is a third-party shareware Win32 Telnet and SSH client. You can use PuTTY to open a terminal session to remote systems that support SSH.

This tool also includes certificate management tools that allow you to assign your private keys. PuTTY and its related binary files are included in the third-party subdirectory of the Capacity Planner installation folder.

Problems with Dashboard Access to the Data

After you set up the Collector and the processes appear to be running, you still might have problems seeing the data on the Capacity Planner Web site.

Check for Missing Data in the Dashboard

Missing data in the Dashboard might be caused by insufficient passage of time or an incorrectly registered database ID.

Inventory data that was uploaded to the Information Warehouse is typically viewable in the Dashboard within 24 hours. However, performance data might not appear until the next business week. This data is summarized and processed at the end of every week, provided that sufficient data was submitted.

Procedure

1. Change the viewing interval from Weekly to Hourly.
2. If you do not see any data from your Collector host in the Dashboard, verify that the database ID for this Collector is properly registered.
Collector Does Not Seem to be Sending Data

Data might be prevented from appearing in the Dashboard for several reasons.

Problem
Data does not appear in the Dashboard.

Cause
A lack of data might indicate that the Collector has not been running long enough or is not registered in the Dashboard. The Scheduler might be suspended and stopped sending data to the Dashboard.

Solution
- Verify that the database ID for this Collector is properly registered in the Dashboard for the correct company.
- Make sure that your scheduled jobs are set up correctly on the Collector host and that the Scheduler is not suspended.
- Make sure that you wait one full business day from setting up the Collector host.

Collection Dashboard Does Not Display Data for a Project

If you do not see collected data on the Project Enterprise or Collection Dashboard page, you might need to add systems for the project.

Problem
- After you register the VMware Capacity Planner Data Manager to the Dashboard, data does not appear on the Project Enterprise or Collection Dashboard page. You might see one or more of the following the errors:
  - Cannot display dashboard: no inventory data has been collected.
  - Cannot display dashboard: no statistics data has been collected.
- When you view the Company Dashboard with which the Project is associated, data does appear in the Enterprise or Collection Dashboard.
- In the Step 1 tab of the Consolidation Estimate (CE) wizard, the CE project is not selected for the In the Data Manager, synchronize the collector with the Dashboard task.

Cause
Appropriate systems are not included in the project.

Solution
1. Add systems for a Consolidation Analysis (CA) or Virtual Desktop Infrastructure (Desktop) project.
   a. Select the Project or Company.
   b. From the Administration menu, select My Projects.
   c. Select the Project and click the Select Systems tab.
   d. Select the systems to include in the project.
   e. Click Apply and click OK.

The added systems now appear on the Enterprise or Collection Dashboard page.
2 Add systems for a CE project.
   a Select the project.
   b Select the Step 1 tab and click Edit Project Info.
   c Click the Select Systems tab.
   d Select the systems to include in the project.
   e Click Apply and click OK.

The added systems now appear on the Enterprise or Collection Dashboard page.

**Collected Data Does Not Appear in the Dashboard**

If you do not see collected data in the Dashboard, you might need to check the internet connection between the Collector host and the Dashboard.

**Problem**

Collected data does not appear in the Dashboard.

**Cause**

Traffic is not going through the HTTP port (443) of the Collector host.

**Solution**

1 To reset the connection between the Data Manager and the Dashboard verify that you can connect to an HTTPS site from the Collector host.
2 Ping the site from the Collector host to verify connectivity.
3 (Optional) If a proxy server is on your network, select Admin > Options > Connection and enter the proxy setting.
4 Select Use Manual Settings and enter the correct proxy setting.

**Capacity Planner 2.8 Collector Does Not Display Logical Drive Information**

In Capacity Planner 2.8, the logical drive information is included in the System Identifiable Information option in the Collector. You must enable this option to send the logical drive information to the Dashboard.

**Problem**

- Logical drive information in the Capacity Planner 2.8 Collector does not appear.
- After initiating data collection with the Capacity Planner 2.8 Collector, the logical drive information does not appear in the Optimize.VMware.com Dashboard.

**NOTE** The problem occurs only in Capacity Planner 2.8.

**Cause**

The System Identifiable Information option is disabled.

**Solution**

- Upgrade to Capacity Planner 3.0.

In Capacity Planner 3.0, the data collection mode collects logical drive information by default.
Enable the System Identifiable Information option in Capacity Planner 2.8.

a. Select Admin > Options > Modules > Inventory > Export.
b. Select Export System Identifiable Information.
c. Select all objects in the exclusion table, except System Information and Logical Volume Information.
   This step ensures that the system and logical volume information are not excluded when exporting. If you do not set the proper exclusions, private data such as your IP address might appear in the Dashboard.
d. Select Force full export of all systems.
   This option is deselected when the next data synchronization process is initiated.

What to do next
In Capacity Planner 2.8, disable the System Identifiable Information option after the logical drive information appears in the Dashboard.

General Collector and Data Manager Issues
You might have to troubleshoot problems with the Collector or Data Manager.

Set Timeout Period
Requests to some target systems might timeout.

To correct this, increase the timeout for one or more modules at the task level.

Procedure
1. From the Capacity Planner menu bar, select Admin > Options.
2. Click the Jobs tab.
3. Select Scheduled - Inventory and click Modify.
4. Click the Tasks tab.
   The Inventory task is listed on the Tasks tab with its Continue On setting and the task time limit, as defined by the task timeout parameter defined for this task.
5. Select the Inventory task and click Modify.
   You must click Modify to change the necessary parameters for this task. Double-clicking the task name on the Tasks tab does not start the necessary dialog box.
6. Select the appropriate module.
7. Set the task timeout and object timeout periods and click OK.

Repeat this process for any other module that is timing out.

Compact a Database
In some instances, an error might occur due to lack of disk space. You can use the Data Manager to compact the database.

Selecting this option frees up disk space in the database through the following actions:

- Copies the compacted database to a temporary file.
- Deletes backup files.
- Renames the uncompacted database with the backup file name.
- Moves and renames the compacted database.

**Note** The database is not compacted.

**Prerequisites**
Verify that the database is not being used by either the Data Manager or Collector.

**Procedure**
1. Set the Log Level to 3 (light debugging) to display the log messages.
2. Select Admin > Database > Compact Database.

**Troubleshoot Collectors**
If data collection is not working as you expect for a particular Collector, use the Troubleshoot Collectors feature. This task is performed from the Dashboard.

**Procedure**
1. Select the company from the drop-down menu.
2. Select Assessment > Collector > Troubleshoot Collectors.
3. Click the failed or excluded link for the Collector.

**Select Tasks Across Collectors for Troubleshooting**
You can select tasks across Collectors for troubleshooting, which typically involves assigning unsuccessful tasks to another Collector. This task is performed from the Dashboard.

**Procedure**
1. If you did not navigate to this page from the Troubleshoot Collectors page or the Support Dashboard, choose the company from the Company filter in the left pane.
2. Select Assessment > Collector > Troubleshoot Systems.
3. Select systems and tasks for troubleshooting.
   - If you plan to reassign most of the tasks to another Collector, select the ones to exclude from reassignment by clicking the check box next to the system name and clicking Exclude.
   - If you plan to reassign only a few tasks to another Collector, select the ones to include for reassignment by clicking the check box next to the system name and clicking Include.
4. Click Details.
5. Make adjustments to the collection configuration.

<table>
<thead>
<tr>
<th>Option</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Account</td>
<td>If you have multiple user IDs, and you want to switch this task to a Collector that you administer under another user ID, select the user ID from the drop-down menu.</td>
</tr>
<tr>
<td>Collector</td>
<td>Select an alternate Collector from the drop-down menu.</td>
</tr>
<tr>
<td>Status</td>
<td>Select Inactive or Active from the drop-down menu.</td>
</tr>
<tr>
<td>Option</td>
<td>Action</td>
</tr>
<tr>
<td>---------</td>
<td>----------------------------------------------------------------------</td>
</tr>
<tr>
<td>Isolate</td>
<td>Indicate whether to isolate this task from consolidation scenarios.</td>
</tr>
<tr>
<td>Inventory</td>
<td>Specify whether to include the task in Inventory Collection.</td>
</tr>
<tr>
<td>Performance</td>
<td>Specify whether to include the task in Performance Collection.</td>
</tr>
</tbody>
</table>

6. Click **Apply** to save the changes or **Revert** to clear the changes.

7. Click **Close** to return to the Troubleshooting Systems page.

8. On the Troubleshooting Systems page, click **Refresh** to force a refresh for the inventory and performance tasks for the systems added on the Collector.

**Missing Data in the Enterprise Dashboard**

Inventory and performance data appears within hours in the Collection Dashboard, but not in the Enterprise Dashboard until at least one week has passed.

**Problem**

Performance data is not appearing in the Enterprise Dashboard.

**Cause**

Either not enough time has elapsed for the data to be processed or there is a problem with data collection.

**Solution**

Allow at least one week for data to appear in the Enterprise Dashboard. On the company system running the Collector, review the messages in the message pane at the bottom of the Data Manager window. Make sure data is being collected.

On the Dashboard, view the Collection Dashboard and try the following options.

- Click the **No data** portion of the consolidatable systems pie chart. The Dashboard displays servers for which there is no data.
- Select **Inventory > Inventory Summary**. The reason why the data was not collected is provided in the Perf Status column.

**Incorrect Dashboard Reports**

Dashboard reports appear to contain incorrect information.

**Problem**

Incorrect information appears in Dashboard reports.

**Cause**

Incorrect information in Dashboard reports can be caused by a number of problems, including incorrect filter settings or an inactive target server.

**Solution**

Check the following items:

- Your filter settings are set appropriately.
- Each target server is active.
- Each target server is monitored.
- Each target server is in the group being considered for consolidation.
Each target server has CPU, RAM, and other vital inventory information.

Each target server has the important performance statistics, for example, System(_Total)/%Processor Time, Processor(_Total)/%Processor Time.

The consolidation scenario is not set to cross boundaries, and a target server is not in a group by itself.

The proposed server group is selected.

Determine if the proposed server is in the server group that is selected.

**Problem Opening a Report**

A generated report cannot be opened.

**Problem**

You are unable to open the generated report without saving it first.

**Cause**

In some cases, when the file is directly opened from the Web, it is stored in the browser temporary file folder. The PDF viewer might not recognize the name and path of the stored file and cannot to open it. An error message might be displayed.

**Solution**

Save the file and then open it.

**Problem with Performance Access Rights**

Incorrect rights and restrictions can disrupt performance collection on a Windows server.

**Problem**

During the connection test, a connection might be successful, but the core Perfmon counters might not be collected.

**Cause**

This error might be because you can log in, but you do not have access rights to read the counters. Lack of access rights might restrict performance monitoring, and create problems with registry permission, local policies, or group policies in Active Directory.

**Solution**

Verify that you have the proper administrator credentials.

**Check Account Rights**

You must make sure that the account or group that you are logging in to is the local Administrators security group to get full access.

If the target server is a domain controller, you must use the Enterprise Admin account to connect to the server.

**Procedure**

1. Select `Start > Run`.
2. Type `lusrmgr.msc` and press Enter.
4. Verify that `Domain Admins` is listed.
5 Select Groups > Performance Monitor Users.
6 Verify that the local service account is in use or that Domain Admins is listed.

**Check Perfmon Registry Access Rights**

If you have access rights, you can browse the registry in the navigation pane to check the access rights.

**Prerequisites**

Verify that you are logged in to the Data Manager.

**Procedure**

1. In the Data Manager, expand the server branch in the navigation pane.
2. Expand the Registry branch.
3. Expand HKEY_LOCAL_MACHINE branch.
   - An Access Denied error should appear.
4. Expand HKEY_CURRENT_USER branch.
   - If an error appears, make sure the login information is valid for that server.
5. Check the access control list for the HKEY_LOCAL_MACHINE key in the registry.
   - The rights should be the defaults.

<table>
<thead>
<tr>
<th>Access Control</th>
<th>Rights</th>
</tr>
</thead>
<tbody>
<tr>
<td>SYSTEM</td>
<td>Full</td>
</tr>
<tr>
<td>Administrator</td>
<td>Full</td>
</tr>
<tr>
<td>Restricted</td>
<td>Full</td>
</tr>
<tr>
<td>Everyone</td>
<td>Full</td>
</tr>
</tbody>
</table>

6. If you cannot access all of the keys, restart the Remote Registry service on the server.

**Check the Local Security Policies**

Some local security policies are set in the Global Policy Options in Active Directory. Some effective policies might need to be selected in Active Directory.

**Procedure**

1. Select Start > Run.
2. Type secpol.msc to open the local security policy manager.
3. Select Profile System Performance.
5. Select Access this computer from the Network.
6. Select Log on as a service.
7. Select Log on locally.
Enable Read Access for Perfmon Registry on the Remote Server

Enabling read access for Perfmon counter keys helps to avoid any network disruptions to the remote server during performance monitoring.

**Note** Local Service and Network Service users do not exist on Windows 2000 servers. You can set permissions in Local System or NT\AUTHORITY\SYSTEM.

**Procedure**

1. Select **Start > Run**.
2. Type `regedit.exe` and press Enter.
3. Navigate to each Perfmon counter key and select a registry key.
   - `HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Perflib`
   - `HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Perflib\009`
   - `HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurePipeServers\winreg`
4. Right-click to select **Permissions** from the drop-down menu.
5. Select **Read** to allow users read access and click **OK**.
   A dialog-box appears.
6. (Optional) From the dialog box, select **Local Service** to allow users read access.

Verify that DCOM Permission Is Enabled

You can configure DCOM permissions to avoid network connection problems.

**Procedure**

1. Select **Start > Run**.
2. Type `regedit.exe` and press Enter.
3. Navigate to the DCOM registry at `HKEY_LOCAL_Machine\Software\Microsoft\Ole\EnableDCOM`.
4. Verify that the DCOM permission is set to **y**.

Resolve Corrupted Perfmon Counter Keys

A corrupted Perfmon counter key causes "Type Mismatch" error (13) error messages to appear in the Collector when you perform data collection.

**Procedure**

1. Select **Start > Run**.
2. Type `regedit.exe` and press Enter.
3. Navigate to the Perfmon counter key at `HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Perflib\009`.
   - If any of the Counter or Help values are numbers instead of words, then the Perfmon counter key is corrupted.
4. Restart the server.
   Restarting the server removes the corrupted copy of the Perfmon counter key from the memory.
5  (Optional) On Windows Server 2003, type `lodctr \r` in the command prompt.

6  If restarting the server fails to fix the problem, rebuild the base Perfmon counter.

7  (Optional) If the Counter or Help values are blank, select the + icon to add a counter.

**What to do next**

To rebuild the base Perfmon counter, see [http://support.microsoft.com/kb/300956](http://support.microsoft.com/kb/300956).
This section documents common errors that you might encounter when running the Capacity Planner Collector and Capacity Planner.

The error messages are listed numerically. Some of the messages have the same message text, but different error codes. Compare the error code with the message text when looking up an error in this appendix. The message you are looking for might be in another section. For example, there are five possible Access Denied messages, each with a different error code. The cause of these messages depends on what you are doing at the time.

This chapter includes the following topics:
- “Data Collection Errors,” on page 25
- “Data Synchronization Errors,” on page 31
- “Miscellaneous Errors,” on page 32

Data Collection Errors

The majority of errors occur during the inventory and performance data gathering processes. These two tasks require successful connection to target systems with permissions that allow various utilities or system services to be run to obtain necessary information.

Collection Through WMI

You can attempt to collect inventory data through a variety of methods. The primary method of collecting inventory data is WMI, therefore majority of inventory collection errors occur when collection is attempted in this manner.

Error Message 438

This error message might appear because of several reasons. Review the possible causes to identify the problem.

Problem

Object doesn’t support this property or method.

Cause

- The class of items does not exist.
- The hardware is outdated.
- Specific hardware drivers do not populate WMI.
- A language problem exists with class names.
Solution

Usually, you cannot do anything in this situation. The Collector continues to collect information from objects that it finds. In some cases, the Collector intentionally tests for the existence of an object before it goes on.

Error Message 214702489

The number and the error message are different if the user is valid but does not have adequate access rights.

Problem

Access is denied.

Cause

The following probable causes could result in an error message.

- Account does not exist.
- Password is invalid.
- User needs to change password on first login.
- Account is disabled.
- User domain cannot be reached for authentication.

Solution

- Check that no misspellings occurred in the account name or domain of the user account, as it is defined for the Collector.
- Retype the password in the Collector to make sure that it is correct.
  The connection account might have been defined in the setup options as a global connection for the Collector or as a custom connection account for the specific target system.
- Log in to the target system with the account to verify that your log-in credentials are correct.
- Check the user account in the domain or target system to verify that it exists, is not disabled, or does not require a password change on first login.
- Check that the target system is in a domain and not in a workgroup with the same name.
- If the user account is not in the same domain as the target system, verify that the proper domain trusts exist.

Error Message 2147023174

A network or service interruption on the target system might cause a server error.

Problem

The RPC Server is unavailable.

Cause

- The target system is offline.
- The remote procedure call (RPC) service is stopped on Collector host or on target system.
- The required ports are blocked.

Solution

Ping the target system and fix any network or service issue.
Error Message 2147024882
In many instances, this error might occur on target systems running Windows NT.

Problem
Inventory error.

Cause
This error happens on systems running Windows NT when the Network Redirector runs out of buffer space when processing a command and the IRPstack is too small for the command to complete.

Solution
Identify and close the applications and utilities that are idle to reclaim space.

Error Message 2147217392
A class error might appear due to several reasons, review the possible causes to identify the problem.

Problem
Invalid class.

Cause
■ The class of items does not exist.
■ The hardware is older.
■ Specific hardware drivers do not populate WMI.
■ There is a possible language issue with class names.

Solution
Usually, there is nothing to do in this situation. The Collector continues to collect information from objects that it finds. In some cases, the Collector intentionally tests for the existence of an object before it goes on.

Error Message 2147217394
An error occurs if WMI is stopped or is not available in the operating system.

Problem
Error description not found.

Cause
The target system is one of the following operating system:
■ Windows NT 4.0 with no WMI
■ Windows 2000 or higher with WMI stopped

Solution
The Collector handles this scenario and switches to Registry when this happens (with default settings). This is normal behavior for Windows NT 4.0 and there is nothing to do because WMI is not available. For Windows 2000 or later, take the following actions:
■ If WMI is shut down for security reasons, do nothing.
■ If WMI is shut down for testing reasons, restart the service.
Error Message 2147217400
A WMI error occurs when you attempt to collect inventory data and there is a problem with a WMI driver.

Problem
Invalid parameter, WMI error.

Cause
Usually, this error appears due to a problem with a WMI driver.

Solution
Use the Registry and not WMI to perform inventory collection.

Error Message 2147217405
An Access Denied error might appear due to several reasons, review the possible causes to identify the problem.

Problem
Access denied.

Cause
Problems with the connection account on the target system can have several causes:
- User does not have enough rights
- User is not in the local administrator group on the target system
- Inherited rights for the user are not sufficient

Solution
- Add the connection account to the local administrators group on the target system.
- If the user is in a domain administrators group, add the domain administrators group to the local administrators group on the target system.

Error Message 2147217407
An error occurs when you attempt to collect inventory data and there is a problem with a WMI driver.

Problem
Failure to collect inventory data.

Cause
Usually, this error appears due to a problem with a WMI driver.

Solution
Use the Registry and not WMI to perform inventory collection.

Error Message 2147221164
A class error occurs if WMI is stopped or is not available in the operating system.

Problem
Class not registered.
Cause
The target system is one of the following operating system:
- Windows NT 4.0 with no WMI
- Windows 2000 or higher with WMI stopped

Solution
The Collector handles this scenario and switches to Registry when this happens (with default settings).
This is normal behavior for Windows NT 4.0, and there is nothing to do since WMI is not available.
For Windows 2000 or later, take the following action:
- If WMI is shut down for security reasons, do nothing.
- If WMI is shut down for testing reasons, restart the service.

Error Message 2147467259
A problem with the Microsoft Jet Database might disrupt collection of inventory data.

Problem
Not collecting inventory.

Cause
The database has been placed in a state that prevents it from being opened or logged.

Solution
Make sure that the Microsoft Jet Database engine can be opened and logged.

Error Message 2147481648
A performance error on a domain might require you to add another Collector to that domain.

Problem
Unable to run performance in some servers.

Cause
You might need another Collector on the domain in which systems are failing.

Solution
If systems that are failing appear to be mostly in one domain, add another Collector for that domain. Add an account that gives you access to the systems in the new domain.

General Data Collection Errors
Some data collection errors can occur with either inventory or performance data collection, independently of the manner you use to collect the data.

Error Message 5
An Access Denied error might appear due to several reasons, review the possible causes to identify the problem.

Problem
Access denied.
Cause
This error usually occurs during inventory data collection and is probably a registry access failure. The user has the rights to connect, but does not have enough rights to read the necessary keys.

Solution
Make sure the connection account has administrative rights on the target system.

Error Message 1792
A service problem during inventory or performance collection might disrupt the process.

Problem
An attempt was made to log on, but the network logon service was not started.

Cause
The net logon service is not running. This condition can occur during either inventory or performance data collection.

Solution
Check the services for the system and make sure that the net logon service is running.

TOOLS Block
A TOOLS block might appear on UNIX or Linux machines due to several reasons, review the possible causes to identify the problem.

Problem
Command = ['[command name]' returned Error = [error that occurred]

An example follows:
Command = 'lsdev' returned Error = not found in /bin:/usr/bin:/usr/sbin:/sbin:/usr/contrib/bin

Cause
This error occurs during data collection on UNIX or Linux machines, or when data collected from these machines using the Collector scripts is imported by data synchronization. The error occurs when scripts used by the Collector cannot find tools or commands that the script expects to find on the target machine. The error message appears in the message box on the Collector host.

The result is that some data cannot be collected, and a TOOLS block appears in the collected data files. Data files are typically found in the C:\Program Files\VMware\VMware Capacity Planner\Temp directory until the data is imported into the Collector. If the Archive option is selected, the files are copied to the C:\Program Files\VMware\VMware Capacity Planner\archive directory.

An example of a TOOLS block follows:
<TOOLS>
HOSTNAME=cp-linux1
FILETYPE=Log
Date=Tue Jan 25 16:20:13 PST 2011
TIMESTAMP=20070206162013
CMD=showmount
ERR=mount clntudp_create: RPC: Program not registered
</TOOLS>
Solution
Install the required tools or commands on the target machine indicated after HOSTNAME=.
The TOOLS block text provides information to help you troubleshoot and fix the problem.

Data Synchronization Errors
Data synchronization errors can occur when the Collector attempts to transmit data files to the Capacity Planner.

Access Denied
An Access Denied error message might appear due to several reasons, review the possible causes to identify the problem.

Problem
Access denied.

Cause
A file transfer was attempted and might not successfully complete for several reasons:
- VMware does not allow files to be overwritten, and the Collector is trying to resend a file with the same name.
- After the file transfer, the Collector is trying to move the file to the archive directory, but the directory is read-only.
- Somehow the file being sent is marked as read-only, and the Collector cannot delete it.

Solution
- Notify VMware of the file causing the error so that the file can be deleted from the upload directory.
- Check the rights to the archive directory to make sure the Collector can write to it.

Invalid Proxy Settings
An invalid proxy setting might cause data transfer failure.

Problem
Can’t send data to VMware.

Cause
Usually, this error is caused by invalid proxy settings.

Solution
- Verify that the Capacity Planner site is available, and that you can log in to the Capacity Planner.
- Check proxy and port settings.

You might need to set the Service User account for the Collector service to an account that has rights to browse the Web outside the company.
Miscellaneous Errors

The Data Manager might show some error messages.

Error Message 713

A dll registration error might occur if Capacity Planner was installed by a different user than the current user.

Problem

Class not registered.

Cause

Capacity Planner was installed as a different user than you are running, which might cause the Capacity Planner to fail because some dlls must be registered for each user.

Solution

When you receive the error message dialog box that shows the .dll name, run the following command: `regsvr32 full.dllpath`

For example:

`regsvr32 c:\winnt\system32\msstdfmt.dll`

Error Message 1726, 1789

An unknown failure error might require you to send log files to technical support.

Problem

A Failed: unknown error message appears in the interface.

Cause

Usually, an error message and code are converted and available to view on the Properties tab of the Details area for the target system on which the error occurred. If the error message does not appear there, it is probably an error code that Capacity Planner has not encountered before.

Solution

View the Properties tab of the Details area for the target system on which the error occurred. If the error does not appear on the tab, contact VMware Technical Support.
## Index

### A
- access denied error 11
- access path testing 12
- account rights 21
- Active Directory 10, 13, 21
- active server 20
- administrator credentials 21
- administrator privileges 11
- automatic database compaction 18

### B
- bad path error 9

### C
- class not registered 32
- Collection Dashboard 16
- collection time, timeouts 18
- collector 19
- Collector
  - data does not appear 17
  - data not uploaded 16
- compacting the database 18
- Computer Management utility 15
- connection issues 8
- connection test 21
- Consolidation Analysis (CA) 16
- Consolidation Estimate (CE) 16
- corrupted Perfmon counter key 23
- current activity 7
- current status 7

### D
- Dashboard 19
- Dashboard access 15
- Dashboard reports 20
- data collection, errors 25, 29
- Data Manager 18
- data missing in the Dashboard 15
- data synchronization errors 31
- data upload, problems 16
- database compaction 18
- DCOM permission 23
- diagnostic tools 13
- discovery, troubleshooting 9
- disk space 18
- display problem, project 16
- domains, missing 9
- dummy domain 9
- duplicate errors 25

### E
- enable, DCOM permission 23
- enable read access 23
- error message
  - 1726 32
  - 1789 32
  - 1792 30
  - 2147023174 26
  - 2147024882 27
  - 2147024889 26
  - 2147217392 27
  - 2147217394 27
  - 2147217400 28
  - 2147217405 28
  - 2147217407 28
  - 214722116 28
  - 2147467259 29
  - 2147481648 29
  - 438 25
  - 5 29
  - 713 32
- access denied 29, 31
- invalid proxy setting 31
- errors
  - access denied 11
  - bad path 9
- collection using WMI 25
- data collection 25
- database compaction 18
- general data collection 29
- logon server not available 12
- miscellaneous 32
- same message text 25
- types 25

### F
- finding systems 9
- firewalls 8
G  
general data collection errors 29
gen generated report 21

H  
host name resolution 12

I  
inactive server 20
incorrect report information 20
Internet connection 17
invalid proxy settings 31
inventory 19

L 
LAN Manager 10
levels of logging 8
Linux 30
LMHOSTS file 9
local security policy 22
logging level, setting 8
Logical Drive information, missing 17
login service 30
logon server not available error 12

M 
miscellaneous errors 32
missing
data in the Dashboard 15
systems 9
missing data 20
missing Perfmon counter key 23

N 
name resolution problems 9
naming services 10
nbstat command 13
net logon service 30
net use command 14
net view command 14

O 
overview, error messages 25

P 
Perfmon, utility 14
Perfmon counter key 23
perfmon keys 23
performance 19
performance access 21
ping command 13
problems, name resolution 9
PuTTY application 15

R 
regedit.exe 15
regedt32.exe 15
registry 21
registry access rights 22
Registry Editor 15
remote registry 22
resolving the host name 12
resources, troubleshooting 7

S 
sending data problems 16
setting, timeouts 18
setting the logging level 8
systems, missing 9

T 
target server 20
testing access paths 12
timeouts, collection 18
TOOLS block 30
tracepath 14
trace route 14
tracert 14
troubleshooting
collection issues 8
data upload 16
discovery 9
resources 7
troubleshooting tools 13

U 
UNIX 30
unknown user 10
unmanaged systems 8
unsuccessful database compaction 18

V 
Virtual Desktop Infrastructure (Desktop) 16

W 
WINS 10
WMI collection errors 25
workaround, discovery 9